WarmupUrls after deploy but before "AfterDeploy"

I figure the title says it all, but my issue is that I am installing a bunch of solutions in a single bundle and when AfterDeploy fires I am Installing and enabling some of the solutions. The iss...

Id #16813 | Release: None | Updated: Jan 28, 2016 at 3:57 PM by matein78 | Created: Jan 26, 2016 at 2:19 PM by maxmanzero

Unhandled exceptions in extensions with "Finalize" event

Hello, I would like to report that exceptions that are thrown by an extension invoked with the Finalize event are unhandled and cause the script to hang, i.e. lock file is never removed. In s...

Id #16812 | Release: None | Updated: Jul 26 at 11:54 AM by ErikBo | Created: May 29, 2015 at 2:24 PM by lapajne

Solution Retraction

Solutions will be retracted, if they are configured within the config. The problem is, that usually you would have the corresponding solution in the solutions folder. If the solution is missing, t...

Id #16811 | Release: SharePoint Solution Deployer 5 | Updated: Dec 5, 2014 at 8:26 PM by matein78 | Created: Dec 4, 2014 at 7:23 AM by ReneHezser

Timer job not found issue

The Deployment fails with following error - Waiting for job 'solution-deploymentXXXXX.wsp*' to start. Timer job for XXXXXX.wsp' not found . It works fine, If I retract the solution before the...

Id #16810 | Release: None | Updated: Jul 26 at 11:55 AM by ErikBo | Created: Nov 5, 2014 at 7:11 PM by modalas

Error at script: Register-Extensions

Hello, I have download the new version and try to deploy a solution: Now I get the error: The term 'Register-Extensions' is not recognized as the name of a cmdlet, funct ion, script file, or o...

Id #16809 | Release: SharePoint Solution Deployer 5 | Updated: Jun 13, 2014 at 10:12 PM by Rickenberg | Created: Apr 14, 2014 at 11:41 AM by wuwu

Farm Solutions do not retract properly

Running Redeploy with farm solutions, function WaitForJobToFinish does not handle successful retraction properly. Given any solution deployed both on CA and a webapplication, WaitForJobToFinish lo...

Id #16797 | Release: None | Updated: Jul 20, 2016 at 6:45 PM by JonatanKapps | Created: Apr 4, 2014 at 8:23 AM by unsafecode

Deployment not working on multi-server farms

Hi, It seems to me that function RecycleAppPools and some of the supporting functions in SPSD_Deployment.ps1 will only work in a single-server farm. The use of Enter-PSSession does not work within...

Id #16790 | Release: None | Updated: Aug 25, 2014 at 9:49 PM by matein78 | Created: Mar 27, 2014 at 9:37 AM by anderaus

New line formatting in the logs - Notepad cannot handle them

Hello team, SPSD has a good log/trace features, no doubts. However, log filed cannot be viewed with Notepad - there are no line breaks, and the nly option is to go either with Wordpad or other 3r...

Id #16750 | Release: None | Updated: Mar 11, 2014 at 9:04 AM by matein78 | Created: Mar 11, 2014 at 12:51 AM by avishnyakov

VS project, "Scripts" folder issue

Hello team, There is a folder called "Scripts" in the VS project template. During the build, all files are copied to the "Package", but folders are missed. Seems that no folders are included in t...

Id #16746 | Release: None | Updated: Mar 11, 2014 at 9:07 AM by matein78 | Created: Mar 7, 2014 at 1:29 AM by avishnyakov

The correct option is "AllWebApplications" and not "allwebapplication"

The file SPSD_Deployment.ps1 has following statement (example - this occurs more than once): Install-SPSolution -Identity $solutionName -allwebapplication -FullTrustBinDeployment:$AllowFullTrustBin...

Id #16734 | Release: None | Updated: Feb 28, 2014 at 11:07 PM by matein78 | Created: Feb 28, 2014 at 12:49 PM by DeChrist